internetnz.nz website outage
Incident Report for InternetNZ
Resolved
This incident has been resolved
Posted Oct 26, 2023 - 17:08 NZDT
Investigating
We're currently investigating an outage of the InternetNZ website.
Posted Oct 26, 2023 - 16:14 NZDT
This incident affected: InternetNZ Websites (internetnz.nz).